Bug Tracker

Opened 11 years ago

Closed 11 years ago

#2343 closed bug (fixed)

[ui.draggable] when i try to move draggable element in "revert" mode on fly return, then flying clone attach to page, break, and loop errors. crash.

Reported by: netdog Owned by: braeker
Priority: major Milestone: 1.2.4
Component: ui Version: 1.2.3
Keywords: revert draggable drag Cc:
Blocked by: Blocking:

Description

When i try to move draggable element in "revert" mode on fly return, then flying clone attach to page, break, and loop errors. crash.

JavaScript Log:

Loop : 
[Break on this error]  if(ui.options.helper != 'original') self.helper.remove();
ui.draggable.ext.... (line 48)
self.helper has no properties
[Break on this error] if(ui.options.helper != 'original') self.helper.remove();
ui.draggable.ext.... (line 48)
self.helper has no properties
[Break on this error] if(ui.options.helper != 'original') self.helper.remove();
...
...

Change History (8)

comment:1 Changed 11 years ago by netdog

You can view this bug here (in FF): http://ca.youtube.com/watch?v=ANxhIDcjpww

comment:2 Changed 11 years ago by paul

I cannot reproduce this issue shown in the video. What version of UI are you using? Make sure you use the latest 1.5b.

comment:3 Changed 11 years ago by netdog

I use lastest jQuery and lastest ui 1.5b.

As I understand this bag appears when one of reverted objects is destructed when there is a holded object on cursor.

set revert:3000 for slower movement of revertment objects. it will help to catch the bag.

---

If you cannot again reproduce this bug, I can record new video. :)

comment:4 Changed 11 years ago by netdog

Note: Bug also produce at UI rev.4783

comment:5 Changed 11 years ago by netdog

I think error in helper destructor. I have tried to use $(this).remove(); instead of "self.helper.remove();" and it fix the bug IMHO :)

$(ui.helper).animate(
				{ 	left: self.originalPosition.left, 		top: self.originalPosition.top } , parseInt(ui.options.revert, 10) || 500,
						function() 		{
							if(ui.options.helper != 'original') {								
								$(this).remove();
								//self.helper.remove();
								//self.clear();

								//console.log('remove');
								//console.log(this);
							}

						}

comment:6 Changed 11 years ago by paul

Owner: changed from paul to rworth

Richard, could you take a look at this? Maybe I'm overseeing something obvious..

comment:7 Changed 11 years ago by paul

Owner: changed from rworth to braeker

comment:8 Changed 11 years ago by braeker

Resolution: fixed
Status: newclosed
Note: See TracTickets for help on using tickets.