Bug Tracker

Opened 8 years ago

Closed 8 years ago

#2337 closed bug (invalid)

jQuery(selector, context) don't work with unbound nodes

Reported by: ieure Owned by:
Priority: major Milestone: 1.2.4
Component: core Version: 1.2.3
Keywords: Cc:
Blocked by: Blocking:

Description

If you pass an array of jQuery selection of un-bound (i.e. not present in the page's DOM) nodes, selectors don't work at all.

Looks like a long-standing bug, I can reproduce it in 1.1.4 and 1.2.3.

Testcase attached.

Attachments (2)

index.2.html (1.0 KB) - added by ieure 8 years ago.
Markup for the testcase
index.html (1.0 KB) - added by ieure 8 years ago.
Testcase reproducing the issue.

Download all attachments as: .zip

Change History (4)

Changed 8 years ago by ieure

Markup for the testcase

Changed 8 years ago by ieure

Testcase reproducing the issue.

comment:1 Changed 8 years ago by ieure

Please ignore index.2.html.

comment:2 Changed 8 years ago by flesler

  • Resolution set to invalid
  • Status changed from new to closed

#id is a 'find' selector, not a filter. That's why it seeks on the document. To filter by ID, use [id=foo] instead.

Note: See TracTickets for help on using tickets.