Bug Tracker

Opened 12 years ago

Closed 12 years ago

#2331 closed bug (worksforme)

Slider range: dragging range causes weird behaviour

Reported by: gregmac Owned by: braeker
Priority: major Milestone: 1.2.4
Component: ui Version: 1.2.3
Keywords: Cc:
Blocked by: Blocking:

Description

This issue can be seen on the demo @ http://dev.jquery.com/view/trunk/ui/demos/ui.slider.html

Adjust both handles so they are each about 1/3 of the way in, and then try to drag the darker area in between the two handles. The expected behaviour is that both handles move, and you are confined to the slider - eg, you are adjusting both handles at once.

What happens though is the two sliders become draggable ghosts, there is no range shown between them, and they are not confined to the slider. When you let go, the ghosts disappear and nothing else happens.

This could possibly be considered an enhancement, but definitely the slider ghosts showing up is a bug.

Change History (3)

comment:1 Changed 12 years ago by paul

Status: newassigned

Dragging the range is currently not possible. I'm working on a implementation.

comment:2 Changed 12 years ago by paul

Owner: changed from paul to braeker
Status: assignednew

comment:3 Changed 12 years ago by joern

Resolution: worksforme
Status: newclosed

Can't reproduce in latest version.

Note: See TracTickets for help on using tickets.