Bug Tracker

Opened 12 years ago

Closed 12 years ago

#2262 closed bug (wontfix)

iFrame problem while using UI Sortables makeSortable

Reported by: BNArun Owned by: codesquare
Priority: major Milestone: 1.2.3
Component: ui Version: 1.2.2
Keywords: ui sortable makeSortable Cc:
Blocked by: Blocking:

Description

I'm using new ui.sortables makeSortable method. When I'm using an iFrame in this, this iFrame is getting refreshed when dragging is started. Fortunately it is not refreshing it's contents while dragging is completed.

Change History (2)

comment:1 Changed 12 years ago by paul

Owner: changed from paul to codesquare

This is something Firefox related. I don't know why it's happening though..

comment:2 Changed 12 years ago by codesquare

Resolution: wontfix
Status: newclosed

The problem is that the drag helper is a clone of the sortable which means it has to create a new iframe (as well as all the other dom nodes) to build the sortable/draggable helper. You'll need to explore using a different helper method or building your sortables without iframes. If the iframe content is domain local you could use an ajax call to get the iframe content and inject it as static content.

Note: See TracTickets for help on using tickets.