Bug Tracker

Opened 12 years ago

Closed 9 years ago

Last modified 9 years ago

#2253 closed bug (duplicate)

iframe bug?

Reported by: suning Owned by:
Priority: low Milestone: 1.next
Component: manipulation Version: 1.4.4
Keywords: iframe clonenode adoptnode Cc:
Blocked by: Blocking:

Description

if in a page Have two "iframe" ,

use it in IE(6/7):

$("iframe").contents().find("body").append("<div>test</div>");

then, A error occur.

Attachments (1)

iframe.zip (29.8 KB) - added by suning 12 years ago.
iframe-test

Download all attachments as: .zip

Change History (8)

Changed 12 years ago by suning

Attachment: iframe.zip added

iframe-test

comment:1 Changed 9 years ago by dmethvin

In IE8, I get an error of "Permission Denied" in jQuery.contents() when I click either button. I also get an "Invalid character" message on line 1 of jquery.js. Notice that the test case is in charset=gb2312.

comment:2 Changed 9 years ago by snover

Keywords: clonenode added
Milestone: 1.2.3
Priority: majorlow

comment:3 Changed 9 years ago by snover

Keywords: adoptnode added

comment:4 Changed 9 years ago by jitter

Resolution: wontfix
Status: newclosed

This is an IE issue. But you can use this workaround

comment:5 Changed 9 years ago by jitter

Component: coremanipulation
Milestone: 1.next
Resolution: wontfix
Status: closedreopened
Version: 1.2.21.4.4

comment:6 Changed 9 years ago by jitter

Resolution: duplicate
Status: reopenedclosed

comment:7 Changed 9 years ago by jitter

Duplicate of #4059.

Note: See TracTickets for help on using tickets.