Bug Tracker

Opened 12 years ago

Closed 12 years ago

#2216 closed bug (fixed)

[validate] javascript error : elem has no properties

Reported by: sluramod Owned by: joern
Priority: major Milestone: 1.2.3
Component: plugin Version: 1.2.2
Keywords: validate Cc:
Blocked by: Blocking:

Description

Hello,

I'm sorry, this is my first bug report related to jquery (one of its plugins, actually).

I get 'elem has no properties' error. I traced it back to line 647 in jquery-1.2.2.js) when I use validator plugin. I think lines 21 and 27 of jquery.validate-1.2.js cause this problem; sometimes this[0] is null. Also, function delegate(event) on line 234 (line 235, actually) is potential source of problems.

Alex

Change History (4)

comment:1 Changed 12 years ago by joern

Owner: set to joern

comment:2 Changed 12 years ago by joern

Resolution: worksforme
Status: newclosed

Could you provide a testpage or at least some testcase? Or a description of the browser in use? Without that I have to assume the error is on your side, because I can't replicate any of the problems mentioned here.

Note that 1.2 needs the delegate plugin, provided in the download as lib/jquery.delegate.js.

comment:3 Changed 12 years ago by joern

Resolution: worksforme
Status: closedreopened

Scott noted that at least one problem is caused by the lack of checking if this[0] is actually defined (a form is selected).

Gonna fix that.

comment:4 Changed 12 years ago by joern

Resolution: fixed
Status: reopenedclosed

Fixed in [4547].

Note: See TracTickets for help on using tickets.