Bug Tracker

Opened 12 years ago

Closed 12 years ago

#2209 closed bug (invalid)

Internet Explorer 6 critical bug with ajax method

Reported by: webmax Owned by:
Priority: minor Milestone: 1.2.3
Component: ajax Version: 1.2.2
Keywords: IE6 bug ajax html Cc:
Blocked by: Blocking:

Description

IE6 bug when big volume data is received using ajax Variable "msg" contains obtained informathion, but method .html doesn't insert it in the page


Example:

$(document).ready(function(){

  $('.headerSearch #search_submit').click(
      function()
      {
        var string = $('.headerSearch #search_field').val();
        if(trim(string).length > 0)
        {
          $('.headerSearch #search_submit').attr('disabled', '1');
          $.ajax({
              type: 'POST',
              url: 'search.php',
              data: 'string=' + string,
              success: function(msg){ 
        $('.headerSearch #search_submit').removeAttr('disabled');
        $('#page').html(msg);}
                 })

        }
        else
        {
          alert('String is small');
        }
    return false;
    }
  );
});

Change History (3)

comment:1 Changed 12 years ago by adamhadani

Hey, I've tried replicating this bug with increasingly larger ( 1024, 2048, 5096, 10192..) sized buffers as ajax responses and could not reproduce it ( IE v6.0.2800.1106 SP1 as well as Firefox 2.0.0.12 just in case.. ). Is this bug still relevant? could you specify an estimate for the volume of data causing this?

comment:2 Changed 12 years ago by flesler

need: CommitTest Case
Priority: criticalminor

comment:3 Changed 12 years ago by flesler

Resolution: invalid
Status: newclosed
Note: See TracTickets for help on using tickets.