Bug Tracker

Opened 12 years ago

Closed 12 years ago

#2199 closed bug (invalid)

Passing arbitrary data to an event trough trigger function doesn't work

Reported by: weenie Owned by:
Priority: critical Milestone: 1.2.3
Component: event Version: 1.2.2
Keywords: Cc:
Blocked by: Blocking:

Description

Example 2 on http://docs.jquery.com/Events/trigger doesn't work. Here the example code:

$("p").click( function (event, a, b) {

when a normal click fires, a and b are undefined for a trigger like below a refers too "foo" and b refers to "bar"

} ).trigger("click", ["foo", "bar"]);

I've done my own example for this (see Attachement).

Attachments (1)

trigger.html (424 bytes) - added by weenie 12 years ago.

Download all attachments as: .zip

Change History (3)

Changed 12 years ago by weenie

Attachment: trigger.html added

comment:1 in reply to:  description Changed 12 years ago by weenie

I think this is not a bug, just didn't understand the docs correctly. You can close this bug report, sorry.

comment:2 Changed 12 years ago by scott.gonzal

Resolution: invalid
Status: newclosed
Note: See TracTickets for help on using tickets.