Bug Tracker

Opened 12 years ago

Closed 12 years ago

#2169 closed bug (duplicate)

1.2.2 Regression with .clone() of "tr" elements in IE 6

Reported by: ieure Owned by:
Priority: major Milestone: 1.2.3
Component: core Version: 1.2.2
Keywords: Cc:
Blocked by: Blocking:

Description

1.2.2 broke .clone() of <tr> elements in IE 6. 1.2.1 works fine.

Testcase attached. If you

Attachments (1)

testcase.html (1.0 KB) - added by ieure 12 years ago.
Testcase. 1.2.1 & 1.2.1 work in Firefox; 1.2.1 works in IE; 1.2.2 breaks in IE.

Download all attachments as: .zip

Change History (3)

Changed 12 years ago by ieure

Attachment: testcase.html added

Testcase. 1.2.1 & 1.2.1 work in Firefox; 1.2.1 works in IE; 1.2.2 breaks in IE.

comment:1 Changed 12 years ago by ieure

Description is cut off. Should say:

If you swap the version of jQuery in the header, you’ll be able to confirm that it works in IE with 1.2.1, but breaks with 1.2.2.

The issue is the clone() call. If you examine the cloned items, you can see that they are empty - they have properties, but nothing is set; even tagName is undefined. This causes the insertBefore() call to fail.

Testcase shows that the problem only affects <tr> elements- the <div>s continue to work.

comment:2 Changed 12 years ago by davidserduke

Resolution: duplicate
Status: newclosed

I'm going to close this as a duplicate of #2184 since I posted the possible patch there and it covers tr as well as some other table elements. I'll link back to this one for the additional information though.

Note: See TracTickets for help on using tickets.