Bug Tracker

Opened 12 years ago

Closed 12 years ago

#2131 closed bug (invalid)

strange behavior for draggable inside fixed position parent

Reported by: scottgonzalez Owned by: paul
Priority: major Milestone: 1.2.2
Component: ui Version: 1.2.1
Keywords: draggable Cc:
Blocked by: Blocking:

Description

When dragging an element that is inside an element that has position: fixed, there is a strange re-drawing problem for the parent element.

See http://www.scottsplayground.com/temp/drag_fixed_container/ for an example. Drag the yellow div to the left of the purple div to see the problem.

Change History (3)

comment:1 Changed 12 years ago by scott.gonzal

Tested in Firefox, IE, Opera and Safari on Windows. The flickering only occurs in Firefox.

comment:2 Changed 12 years ago by scott.gonzal

If using a clone or ghosting, this can be avoided by appending the helper to the body: $('#drag').draggable({

ghosting: true, appendTo: document.body

});

comment:3 Changed 12 years ago by paul

Resolution: invalid
Status: newclosed

Cannot reproduce it on FF Mac, but I can reproduce it with FF Win. This means it's definitely a rendering issue within the OS/Browser, and unfortunately unfixable for us. Thanks anyway!

Note: See TracTickets for help on using tickets.