Skip to main content

Bug Tracker

Side navigation

#2086 closed bug (worksforme)

Opened December 21, 2007 01:19AM UTC

Closed August 11, 2010 11:24PM UTC

Last modified March 14, 2012 06:16AM UTC

Animate Method is buggy when changing font size with em units (IE bug only)

Reported by: ajma Owned by:
Priority: minor Milestone: 1.2.4
Component: effects Version: 1.2.1
Keywords: animate Cc:
Blocked by: Blocking:

I have a chunk of code that animates fontsize changes with the units

set to em. The animation is a bit wacky. The text is supposed to get larger, but it gets smaller then grows larger.


#test {




<div id="test" href="">Test</div>

<script type="text/javascript">

$('#test').mouseover(function() {



$('#test').mouseout(function() {




Attachments (2)
Change History (5)

Changed May 11, 2008 10:58PM UTC by flesler comment:1

component: corefx

Changed June 08, 2009 05:25PM UTC by eveningsky comment:2

Replying to [comment:1 flesler]:

I've attached an example that displays the issue. Just hover on and off the link in IE.

Changed June 08, 2009 05:31PM UTC by eveningsky comment:3

Replying to [comment:2 eveningsky]:

Replying to [comment:1 flesler]:

And its not restricted to ems. I tried changing everything to pixels in the example and it still faltered.

Changed August 11, 2010 11:24PM UTC by dmethvin comment:4

resolution: → worksforme
status: newclosed

This seems to be working for me in 1.4.2 with IE8 and IE7. Test case attached.

Changed August 11, 2010 11:29PM UTC by dmethvin comment:5

Also, the original test case (which is more complicated) worked fine with 1.4.2 substituted.