Bug Tracker

Opened 13 years ago

Closed 12 years ago

#2036 closed bug (worksforme)

Safari 2.0.4 - ui.Tabs randomly does not update classes on tab switch

Reported by: gt2304b Owned by: klaus
Priority: minor Milestone: 1.2.1
Component: ui Version: 1.2.1
Keywords: tabs safari hover Cc:
Blocked by: Blocking:

Description

browser: Safari 2.0.4 OS: Mac OS X 10.4.8

Steps to reproduce:

  1. create remote tabs, w/ caching disabled
  2. click on a non-selected tab and while it's loading, move the mouse cursor down away from the tab area.
  3. repeat step 2

================= eventually, (occurs about once every five clicks) the "unselected" tab (the one that was previously selected) will retain the :hover CSS style, instead of the normal (unselected/non-hovered) tab style.

It seems like this is a browser bug, where that particular tab for some reason is being stuck on :hover. (once you mouseover the tab, and then mouse out, the proper styling will be applied).

I've been searching for a workaround, but to no avail. Are there any suggestions to patch the plugin so that it will "force" safari to remove the :hover state from the tab?

Thanks for the great plugin! -john

Change History (2)

comment:1 Changed 13 years ago by klaus

Owner: set to klaus

comment:2 Changed 12 years ago by klaus

Resolution: worksforme
Status: newclosed

could not reproduce at all

Note: See TracTickets for help on using tickets.