Bug Tracker

Opened 13 years ago

Closed 13 years ago

Last modified 13 years ago

#1966 closed bug (invalid)

Bizarre "shrinking body" bug in IE

Reported by: davestewart Owned by:
Priority: major Milestone: 1.2.1
Component: core Version: 1.2.1
Keywords: shrink, body tag, 16px Cc:
Blocked by: Blocking:

Description

Hi, I'm getting completely bizarre behaviour in IE.

Basically, as soon as ANY JQuery command is issued, for example a bind() event, a hasClass call, or slideUp iteration, the body tag SHRINKS 16 pixels, up to the top-left hand corner (complete with scrollbars), until you can't see any of the web page any more! You can lose an entire page in about 2 seconds.

It doesn't happen in my colleague's IE, but it's happening to me (version 6). Check this page to see:

http://www.davestewart.co.uk/portfolio/html/list-jquery-bug.php

Her is an animated gif to illustrate what is happening in case your IE doesn't do this:

http://www.davestewart.co.uk/temp/jquery-shrinking-body.gif

If the doctype declaration is removed it behaves itself (but I need it for my css rendering).

What the hell is going on!?

Thanks, Dave Stewart

Change History (2)

comment:1 Changed 13 years ago by davidserduke

Resolution: invalid
Status: newclosed

While I admit it is bizarre, this is unlikely to be a jQuery bug. A better forum for getting help on solving jQuery problems on an individual web site can be found on the jquery google group:

http://groups.google.com/group/jquery-en

If this is somehow found to be a jQuery bug please create a simplified test case of the situation and reopen the bug. Thanks.

comment:2 Changed 13 years ago by davestewart

I managed to track down the cause of the bug, and I although do think it's partly jQuery related, it may be such a rare case that perhaps it's not worth bothering with?

It was something to do with having the html and body css set to hidden then in a new selector having the body set to scroll (not exactly, but that's the gist). I know as I removed a rule and everything was fine again.

I was so busy that I didn't have time to post a repro case, but I can if necessary. In the mean time, case closed, I guess.

Thanks for looking.

Note: See TracTickets for help on using tickets.