Bug Tracker

Opened 13 years ago

Closed 13 years ago

#1882 closed bug (worksforme)

.attr('height','250px') causing exception being thrown in IE6

Reported by: ventura Owned by:
Priority: minor Milestone: 1.2.2
Component: core Version: 1.2.1
Keywords: attr Cc:
Blocked by: Blocking:

Description

It happens when I use jQuery with a particular script on a particular page layout. In this particulary particular configuration the exception is always thrown on IE6 (working fine on other browsers).

I've modified line 907 into this: try {

this is the original line if ( value != undefined ) elem[name] = value;

} catch (exp) {

window.alert("elem: "+ elem+"\nname: " +name + "\nvalue:" + value + "\nexception: " + exp.message );

}

and I get a message box saying the following:

elem: [object] name: height exception Invalid Argument.

I also tried to gather a stack trace to verify what calls this function (or on which object is this being originaly called) but I didn't have any success so far. Any tips on gathering such information would be really nice. Any solutions other than leaving an empty try-catch woule be even better (this does solve my problem without any secondary effects...).

Change History (2)

comment:1 Changed 13 years ago by brandon

need: ReviewTest Case

What element are you setting height on? Why not use .css('height', '250px')? Could you provide a test case?

comment:2 Changed 13 years ago by brandon

Resolution: worksforme
Status: newclosed

I'm not able to reproduce this issue. Feel free to reopen the ticket with a simplified test case.

Note: See TracTickets for help on using tickets.