Bug Tracker

Opened 13 years ago

Closed 13 years ago

#1877 closed bug (invalid)

$.get in IE6

Reported by: shatrov Owned by:
Priority: critical Milestone: 1.2.2
Component: ajax Version: 1.2.1
Keywords: Cc:
Blocked by: Blocking:

Description

this code don`t working in IE6 (in FF and Opera - ok)

$(function(){
  $.get("/mod/catalog/item.php?item_id="+id,
    {type: "xml"},
    function onAjaxSuccess(xml){
      alert("Data Loaded: " + $("title", xml).text());
    }
  );
});

Change History (2)

comment:1 in reply to:  description Changed 13 years ago by shatrov

Sorry, it`s my bug!

I add this code in item.php and all work true:

<?php if($_GETbrowser?=="ie"){

header("Content-type: text/xml");

} else{

header("Content-type: application/xhtml+xml");

} ?>

comment:2 Changed 13 years ago by Bradley

Resolution: invalid
Status: newclosed

Submitter asserts this is not a bug. Marking invalid. Repost if necessary.

Note: See TracTickets for help on using tickets.