Bug Tracker

Opened 13 years ago

Closed 13 years ago

#1873 closed bug (duplicate)

.html() bug with IE

Reported by: frankysanders Owned by:
Priority: major Milestone: 1.2.2
Component: core Version: 1.2.1
Keywords: Flash External Interface Cc:
Blocked by: Blocking:

Description

Loading flash swf's has an issue with .html. When loading a swf via {#id}.html('swf') Flash External Interface methods will not initialize properly. This bug only occurs with IE and does not seem to be an issue with Safari or FireFox.

Although {#id}.html('swf') does't work, writing a SWF via id.innerHTML='swf' seems to be fine. I'm not sure what's going on under the hood but I know that this release of jquery has some issues with Active X controls. (Or at least the compressed version did). I've attaced a demo movie illustrating the bug. I am currently trying to come up with a solution but as of yet I have been unable to.

Change History (1)

comment:1 Changed 13 years ago by davidserduke

Resolution: duplicate
Status: newclosed

Appears to be a duplicate of #1874 so I'll close this one.

Note: See TracTickets for help on using tickets.