Bug Tracker

Opened 12 years ago

Closed 12 years ago

#1744 closed bug (worksforme)

$.ajax success callback doesn't receive json data

Reported by: carl Owned by:
Priority: major Milestone: 1.2.2
Component: ajax Version: 1.2.1
Keywords: Cc:
Blocked by: Blocking:

Description

when using $.ajax({dataType: "json", ...}) the ajax.onreadystatechange function in jquery-1.1.3.1 used to call s.success( data, status ) but in 1.2.1 it just calls s.success().

Attachments (2)

jquery_test.html (873 bytes) - added by davidserduke 12 years ago.
test case (based on description)
json.js (19 bytes) - added by davidserduke 12 years ago.
test case data

Download all attachments as: .zip

Change History (4)

comment:1 Changed 12 years ago by Bradley

Component: coreajax
Priority: blockermajor

Changed 12 years ago by davidserduke

Attachment: jquery_test.html added

test case (based on description)

Changed 12 years ago by davidserduke

Attachment: json.js added

test case data

comment:2 Changed 12 years ago by davidserduke

need: ReviewTest Case
Resolution: worksforme
Status: newclosed

Couldn't reproduce this bug with the above test case I built based on the description in either 1.2.1 or today's SVN. Nor could I see a place in 1.2.1 where s.success() was called without parameters.

Please reopen if you find a test case that fails.

Note: See TracTickets for help on using tickets.