Bug Tracker

Opened 12 years ago

Closed 12 years ago

#1667 closed bug (duplicate)

sortable callbacks not working

Reported by: intrktevo Owned by: john
Priority: critical Milestone: 1.2.2
Component: ui Version: 1.2.1
Keywords: Cc:
Blocked by: Blocking:

Description

The start callback works, but the update/stop ones do not.


Here is my code:

$("#menudrawer").sortable({hoverClass: 'sorthover', change: function() { console.log("change");} });


What happens is the word change gets written to the firebug log, then an infinite number of errors (all the same) saying:

this.parentNode has no properties

http://kflocal/js/jquery.js

Line 23


End result: I cannot call any functions when an item is moved.

Change History (2)

comment:1 Changed 12 years ago by paul

Owner: set to john

John - this is the famous triggerHandler issue - it also happens with Firebug disabled.

comment:2 Changed 12 years ago by john

Resolution: duplicate
Status: newclosed

Duplicate of #1679.

Note: See TracTickets for help on using tickets.