Bug Tracker

Opened 13 years ago

Closed 12 years ago

#1636 closed enhancement (invalid)

icky of jquery UI vs. interface elements

Reported by: florianb Owned by: paul
Priority: major Milestone: 1.2.1
Component: ui Version: 1.2
Keywords: Cc:
Blocked by: Blocking:

Description

I've noticed that jquery UI with the fisheye and the list sortable demos are a bit icky.

  • machine: Intel Core2 Duo 2.13 MHz, 2GB ram (1Gb free), Nvidia 5900 Ultra 256mb
  • operating system: ubuntu feisty (with desktop effects enabled)
  • browser: firefox 2.0.0.6

fisheye

sortable nested list

Attachments (4)

interface_elements_dragdrop_list.ogg (124.3 KB) - added by florianb 13 years ago.
Interface Elements drag&drop sortable list
interface_elements_fisheye.ogg (154.3 KB) - added by florianb 13 years ago.
Interface Elements fisheye menu
jquery_ui_dragdrop_list.ogg (70.3 KB) - added by florianb 13 years ago.
jquery UI drag&drop sortable nested list
jquery_ui_fisheye.ogg (132.5 KB) - added by florianb 13 years ago.
jquery UI fisheye menu

Download all attachments as: .zip

Change History (10)

Changed 13 years ago by florianb

Interface Elements drag&drop sortable list

Changed 13 years ago by florianb

Interface Elements fisheye menu

Changed 13 years ago by florianb

Attachment: jquery_ui_dragdrop_list.ogg added

jquery UI drag&drop sortable nested list

Changed 13 years ago by florianb

Attachment: jquery_ui_fisheye.ogg added

jquery UI fisheye menu

comment:1 Changed 13 years ago by florianb

I tested on the same system with opera, and it's nice and fluid. However on opera interface elements still feels a tick better.

comment:2 Changed 13 years ago by florianb

I tested with konqueror and there the effect is much amplified. Interface Elements runs smooth and normal, but jquery UI is extremely icky (much more then on mozilla)

comment:3 Changed 13 years ago by paul

Resolution: invalid
Status: newclosed

Hi, these performance issues cannot easily be grouped into a single task. As for sortables, I have already plans for speeding them up, but I don't know yet for magnifier. Thanks for your information!

comment:4 Changed 13 years ago by florianb

If you're going to split this ticket in multiple please include the ticket URLs you've opened for it.

comment:5 Changed 13 years ago by florianb

Resolution: invalid
Status: closedreopened

This issue hasn't been addressed so far, there was no comment that other tickets would address this. I researched the issue and showed in the most clarity that the issue is real and problematic. I rechecked with the current demo, it is still an issue.

Please don't dismiss valuable input.

comment:6 Changed 12 years ago by paul

Resolution: invalid
Status: reopenedclosed

What is still real and problematic? Where is the issue? I will happily close all tickets related loosely to performance/ickyness, because it's absolutely not possible to fix them this way.

I'm thankful for all input, but please don't go against the project lead's decision to close the issue and to create separate tickets for specific cases. If you really need to reopen the ticket, attach valid information. Thank you.

Note: See TracTickets for help on using tickets.