Bug Tracker

Opened 13 years ago

Closed 12 years ago

#1633 closed bug (worksforme)

Bindings in Ajax content stopped working in 1.2.1

Reported by: back-2-95 Owned by:
Priority: major Milestone: 1.2.2
Component: core Version: 1.2
Keywords: bind Cc:
Blocked by: Blocking:

Description

When I upgraded 1.2 to 1.2.1, all my bind commands in Ajax content stopped working.

For example I have following js-code in Ajax-content:

<script type="text/javascript">

$("ul#tools a").bind (

"click", function() {

openDialog($(this).attr("href"));

return false;

}

);

</script>

$("ul#tools a") seems to find object but it won't bind anything to them.

I normal content bind seems to work. And in 1.2 it works in both normal and Ajax content.

Attachments (1)

jquery_test.html (690 bytes) - added by davidserduke 12 years ago.
test case (built based on description)

Download all attachments as: .zip

Change History (3)

comment:1 Changed 13 years ago by davidserduke

I couldn't reproduce this bug unless the DOM wasn't ready yet.

Adding $(document).ready() to your code it seemed to work fine.

Changed 12 years ago by davidserduke

Attachment: jquery_test.html added

test case (built based on description)

comment:2 Changed 12 years ago by davidserduke

Milestone: 1.2.11.2.2
need: ReviewTest Case
Resolution: worksforme
Status: newclosed

I built a test case based on the description and it works for me. If you have a test case that fails please reopen the ticket and attach it.

Note: See TracTickets for help on using tickets.