Bug Tracker

Opened 13 years ago

Closed 13 years ago

#1631 closed bug (invalid)

$( '*', '.context' ).length returns n in FF and n+1 in IE

Reported by: aercolino Owned by:
Priority: major Milestone: 1.2.1
Component: core Version: 1.2
Keywords: Cc:
Blocked by: Blocking:

Change History (6)

comment:1 Changed 13 years ago by davidserduke

I was unable to reproduce this bug in 1.2.1 with

<div class="context"> <a href="#">Link 1</a> <a href="#">Link 2</a> <a href="#">Link 3</a> </div>

In IE6/7 and FF2 the length returned as 3. I also didn't see any differences in your example. Did the latest release fix this problem?

comment:2 Changed 13 years ago by aercolino

I think I don't undestand...

Do you have opened the link I provided in IE7 and in FF2?
The 4th selection is $( '*' ) and if you hover it, its length is 13 in FF2 and 14 in IE7.

comment:3 Changed 13 years ago by aercolino

comment:4 Changed 13 years ago by davidserduke

Odd, running your example I get 13 for in both FF2 and IE7. Below is the Generated Source for both FF (using Web Developer plugin) and IE (using this bookmarklet).

javascript:document.write(document.body.innerHTML.replace(/</g,'&lt;'));

In IE7 I got

<TD jQuery1191357893890="22">13: DIV, DIV, DIV, P, DIV, DIV, DIV, DIV, P, DIV, DIV, H5, P</TD>

and in FF2 I got

<td>13: DIV, DIV, DIV, P, DIV, DIV, DIV, DIV, P, DIV, DIV, H5, P</td>

What meta tag are you seeing?

comment:5 Changed 13 years ago by aercolino

I've just found that the problem is bigger, so I've opened a more general ticket: http://dev.jquery.com/ticket/1771

I have a weird meta tag added somehow by Skype in IE... it causes the n / n+1 difference between FF and IE.

I think that this ticket could be closed in favor of the new one.

comment:6 Changed 13 years ago by davidserduke

Resolution: invalid
Status: newclosed

See related ticket #1771 for more details on why it is closed.

Note: See TracTickets for help on using tickets.