Bug Tracker

Opened 13 years ago

Closed 13 years ago

#1627 closed bug (fixed)

BUG: IE6 png fix and fadeIn

Reported by: jonahfox Owned by:
Priority: minor Milestone: 1.2.2
Component: core Version: 1.2
Keywords: Cc:
Blocked by: Blocking:

Description

bug in 1.2 (and previous jqueries) when using png fixes and effects such as fadeIn()

line 881.

(parseFloat( elem.filter.match(/opacity=([)]*)/) )[1]) / 100).toString() : "";

The problem is caused, because elem.filter is not null (using DXAlpha..) but does not match /opacity/ and thus we are attempting to evaluate null[1]

it can be fixed with =>

(parseFloat( (elem.filter.match(/opacity=([)]*)/)
[0,"100"])[1]) / 100).toString() : "";

Change History (1)

comment:1 Changed 13 years ago by davidserduke

Milestone: 1.2.11.2.2
Resolution: fixed
Status: newclosed

I believe this is fixed in [4013]. Although the fix was not for this specific ticket, the result was a non-null filter that doesn't have opacity in it should now work.

Note: See TracTickets for help on using tickets.