Bug Tracker

Opened 13 years ago

Closed 12 years ago

#1617 closed bug (worksforme)

Size and Length doesn't work

Reported by: suduj Owned by: brandon
Priority: major Milestone: 1.2.2
Component: core Version: 1.2
Keywords: size, length Cc:
Blocked by: Blocking:

Description

Size() and length count wrong number of rows after cloning row in table. If table have 3 rows before cloning, size() or length shows 3 rows after cloning 1 row.

$("#tableid tbody tr:eq(2)").clone().insertAfter("#tableid tbody tr:eq(0)");

alert('Size:' + $("#tableid tbody tr").size() + ', Length:' + $("#tableid tbody tr").length);

Previous version of jQuery shown 4 rows.

Attachments (1)

jquery_test.html (899 bytes) - added by davidserduke 12 years ago.
test case

Download all attachments as: .zip

Change History (4)

comment:1 Changed 13 years ago by john

Owner: set to brandon

comment:2 Changed 13 years ago by davidserduke

I was unable to reproduce this bug in 1.2.1 in IE6/7 or FF2. Fixed?

Changed 12 years ago by davidserduke

Attachment: jquery_test.html added

test case

comment:3 Changed 12 years ago by davidserduke

Milestone: 1.2.11.2.2
Resolution: worksforme
Status: newclosed

I was unable to reproduce it in Opera or Safari either with the above test case that I built based on the description. If you can make a test case that reproduces this bug please do so and reopen it.

Note: See TracTickets for help on using tickets.