Bug Tracker

Opened 12 years ago

Closed 12 years ago

Last modified 8 years ago

#1573 closed bug (wontfix)

Slidedown double take in Firefox

Reported by: sheetzam Owned by:
Priority: major Milestone: 1.2.2
Component: effects Version: 1.2.1
Keywords: Cc:
Blocked by: Blocking:

Description

This happens in Firefox v 2.0.0.6 on the mac (not sure about other platforms). When a div is hidden and activated with hover, it slides open, closes, then open again. Doesn't do it every time, and seems to happen most if you reload the page then hover again. There is an example at http://test2.zurka.com/bug I'll try to attach the example also

Attachments (1)

bug.zip (245.8 KB) - added by sheetzam 12 years ago.

Download all attachments as: .zip

Change History (4)

Changed 12 years ago by sheetzam

Attachment: bug.zip added

comment:1 Changed 12 years ago by john

Component: corefx
Milestone: 1.2.1
Version: 1.1.41.2

comment:2 Changed 12 years ago by davidserduke

Near as I can tell this is a FF bug. The problem happens (reproduced using bug.zip) when you move the mouse in to the webpage menu from above which is out of the document area. On my machine I was able to reproduce it more than half the time when coming in from above by moving quickly from out of the document area to the middle of the orange stripe for Now At. I can reproduce it near 100% by quickly running over the whole image from above the document to below the image.

When reproducing the bug by stopping in the orange title bar there is (not surprisingly) an extra set of mouseover and mouseout events. All 3 of them have a e.relatedTarget == 'undefined'.

From this I'd draw that the problem happens when the mouse events go from outside the document area directly to the observed area which would explain the 'undefined' related target. But that doesn't explain why there is an extra set of mouseover/mouseout events.

The only oddity I see by looking at the event itself is clientX and clientY. For the 3 events (mouseover, mouseout, mouseover) which happen on the one mouse move of maybe 20 pixels from above the document to inside the top orange bar the coordinates change significantly. By attaching my own listener directly to FF (using addEventListener) it returns the following for the 3 events.

mouseover, screenX=453, screenY=121, clientX=185, clientY=2

mouseout, screenX=453, screenY=121, clientX=453, clientY=97

mouseover, screenX=453, screenY=121, clientX=185, clientY=2

I suspect the mouseout client coordinates are so different because they are related to outside the document area which suggests on the one mouse move FF thinks the mouse is moving into the document area then out again then back in while the mouse is definitely not doing that as you can tell by the screenX/Y.

I should note that if it was an instantaneous highlight instead of one created over time this likely wouldn't be seen. Right now I can't think of a work around except perhaps to actually check if the mouse is really not over element before doing the mouseout function. I'll leave that as an exercise for anyone interested. =P

That is my brain dump for anyone interested enough to have read this far.

comment:3 Changed 12 years ago by john

Milestone: 1.2.11.2.2
Resolution: wontfix
Status: newclosed
Version: 1.21.2.1

Yeah, this is probably something that we won't be able to resolve. If Firefox is lying to us about the mouse position there's not much that we can do.

Note: See TracTickets for help on using tickets.