Bug Tracker

Opened 13 years ago

Closed 12 years ago

Last modified 8 years ago

#1560 closed bug (wontfix)

ScrollToAnchors

Reported by: saturnflyer Owned by: stefan
Priority: minor Milestone: 1.2
Component: interface Version: 1.1.4
Keywords: Cc:
Blocked by: Blocking:

Description

Ticket #924 is closed, but as far as I can tell in my code the problem still exists.

ScrollToAnchors kills any link that has a # with return false. It is likely that most same-page anchor links will begin with # and not have any characters preceding it. Links to external page anchors will only contain # and not begin with it. The selector should then be href="#" instead of href*="#"

ScrollToAnchors does not work on named anchors (non-ID attributes). I'm not sure if this is by design, but it would be nice if it did work on named anchors.

Once this is done, the scroll animation on external pages does not happen. As a convention of using ScrollToAnchors it might make sense to always animate the scroll. Perhaps adding a ready() call to check the url and animate to the anchor.

Attachments (1)

scroll.diff (1.2 KB) - added by saturnflyer 13 years ago.
ScrollToAnchors behavior changes

Download all attachments as: .zip

Change History (2)

Changed 13 years ago by saturnflyer

Attachment: scroll.diff added

ScrollToAnchors behavior changes

comment:1 Changed 12 years ago by scott.gonzal

Resolution: wontfix
Status: newclosed

Interface is no longer supported; consider switching to jQuery UI.

Note: See TracTickets for help on using tickets.