Bug Tracker

Opened 13 years ago

Closed 13 years ago

Last modified 8 years ago

#1542 closed bug (invalid)

$.ajax not working properly in IE7

Reported by: austin Owned by:
Priority: major Milestone: 1.2.2
Component: ajax Version: 1.1.4
Keywords: Cc:
Blocked by: Blocking:

Description

It appears that the update to 1.1.4 broke something in IE7 for ajax. For example:

Calling a file like info.php which just returns html passes correctly to function on the end for alert but you are unable to use the value anywhere else in the document.

Works:

$.ajax({
	data: "id=1",
	type: "GET",
	url: 'somefile.php',
	dataType: "html",
	async: 'false',
	success: function(data) {
		alert(data);
	}
});

Does NOT work in 1.1.4 but DOES work in 1.1.3.1:

$.ajax({
	data: "id=1",
	type: "GET",
	url: 'somefile.php',
	dataType: "html",
	async: 'false',
	success: function(data) {
	 $("#some_div_id").html(data);
	}
});

This makes the div become empty which makes me think the variable is being set to null or is being destroyed completly.

This makes me wonder something at a basic level is failing with respect to IE7. This bug does not happen in IE6, Opera 9.22, FF and Safari 2.0.4 for Mac.

What is also interesting is that is appears $.get() does not work in 1.1.3.1 or 1.1.4. I have not tried any earlier versions as I do not use it.

Change History (3)

comment:1 Changed 13 years ago by austin

It appears that I had something in my code somewhere that was causing IE to die but the other browsers to work. So it is something specific to IE7. I am going to look and see if I can find the cause.

However $.get() I can not get to work even with the simplest return of html or just plain text.

comment:2 Changed 13 years ago by austin

I figured out for my purposes. There was an extra floating </div> that I never caught because it never stopped working until I upgraded to 1.1.4. I appears whatever was changed in this version "broke" it only for IE7. Not sure if it is some kind of eval or something but disregard this bug report otherwise.

Sorry.

comment:3 Changed 13 years ago by Bradley

Milestone: 1.21.2.2
Resolution: invalid
Status: newclosed

Submitter asserts this is not a bug. Marking invalid. Repost if necessary.

Note: See TracTickets for help on using tickets.