Bug Tracker

Opened 13 years ago

Closed 13 years ago

#1539 closed bug (duplicate)

Error in detect IE version with Mail.Ru Agent installed

Reported by: VLAD Owned by:
Priority: major Milestone: 1.2
Component: core Version: 1.1.4
Keywords: Cc:
Blocked by: Blocking:

Description

There is UserAgent: "mozilla/4.0 (compatible; msie 6.0; windows nt 5.1; mra 4.6 (build 01425); .net clr 2.0.50727)" (it's IE6 on WindowsXP and Mail.Ru Agent 4.6, instant messenger).

$.browser.version is equal "4.6" on this situation, and it is error.

As I see in /trunk/jquery/src/jquery/jquery.js, trouble in line 1973 on suffix "ra" (for detection opera)

version: (userAgent.match(/.+(?:rv|it|ra|ie)[\/: ]([\d.]+)/) || [])[1],

Change History (1)

comment:1 Changed 13 years ago by brandon

Resolution: duplicate
Status: newclosed

Duplicate of #1537

Note: See TracTickets for help on using tickets.