Bug Tracker

Opened 4 years ago

Closed 4 years ago

Last modified 4 years ago

#15250 closed bug (duplicate)

IE 11 Compatibility Mode - Aria attributes and "Member not found"

Reported by: BrainFooLong Owned by:
Priority: undecided Milestone: None
Component: unfiled Version: 1.11.1
Keywords: Cc:
Blocked by: Blocking:

Description

I have found a bug in jQuery 1.11.1 that breaks all scripts the want to set "aria-" attributes in IE11 compatibility mode. The bad thing is that compatibility mode is mostly enabled in "intranet" pages in my company. I know that compatibility mode is the badass of the evil but unfortunately here it is mostly enabled because of stoneold software.

Steps to reproduce

  1. http://bfldev.com/tablesorter-bug/test.html
  2. Enable compatibility mode in IE for domain "bfldev.com". (Gear icon at top right -> Compatibility mode settings)
  3. Reload and watch the console error "Member not found".

Greetz

Change History (2)

comment:1 Changed 4 years ago by dmethvin

Resolution: duplicate
Status: newclosed

Duplicate of #12577.

comment:2 Changed 4 years ago by BrainFooLong

I recommend the jQuery team to fix this issue because obviously microsoft doesn't care about that bug. A bug that exist 2 years in various versions and also in the newest DEV Channel of IE. I see no chance to get this fixed by microsoft.

Note: See TracTickets for help on using tickets.