Bug Tracker

Opened 5 years ago

Closed 5 years ago

#15192 closed bug (invalid)

.toggle() is broken on fragment

Reported by: bl4ckdu5t Owned by: bl4ckdu5t
Priority: low Milestone: None
Component: css Version: 2.1.1
Keywords: Cc:
Blocked by: Blocking:

Description

Hello, Recently from a test of the .toggle() by a member on the #jQuery IRC channel on irc.freenode.net , it was discovered that .toggle() method is broken on fragments. This fiddle shows an example of its usage and how it failed http://jsfiddle.net/bl4ckdu5t/4rAFr/1/ . Suggestion is that there may be something on this ()https://github.com/jquery/jquery/blob/c869a1ef8a031342e817a2c063179a787ff57239/src/css.js#L451 part of the code that needs to be fixed.This was tested by me on my Chromium 35.0.1916.153 in my Debian 7.6 machine. Thanks, Joseph Rex

Change History (2)

comment:1 Changed 5 years ago by timmywil

Component: manipulationcss
Owner: set to bl4ckdu5t
Priority: undecidedlow
Status: newpending

This may just be expected behavior. No matter how many times .show() is called on a disconnected element, it is not shown until it is attached to the document.

Updated example: http://jsfiddle.net/timmywil/u782b/1/

What is the use case here?

comment:2 Changed 5 years ago by trac-o-bot

Resolution: invalid
Status: pendingclosed

Because we get so many tickets, we often need to return them to the initial reporter for more information. If that person does not reply within 14 days, the ticket will automatically be closed, and that has happened in this case. If you still are interested in pursuing this issue, feel free to add a comment with the requested information and we will be happy to reopen the ticket if it is still valid. Thanks!

Note: See TracTickets for help on using tickets.