Bug Tracker

Opened 8 years ago

Closed 8 years ago

Last modified 8 years ago

#15191 closed bug (duplicate)

serializeArray fails with fieldset in IE

Reported by: ddewit Owned by:
Priority: undecided Milestone: None
Component: ajax Version: 2.1.0
Keywords: Cc:
Blocked by: Blocking:

Description

serializeArray returns an empty array when used on a fieldset in IE, works fine in other browsers.

See this fiddle: http://jsfiddle.net/Wh4dK/1/

Change History (4)

comment:1 Changed 8 years ago by gibson042

Resolution: duplicate
Status: newclosed

Duplicate of #13357.
fieldset is not documented as valid input at http://api.jquery.com/serializeArray/.

See also:

comment:2 Changed 8 years ago by ddewit

So, it would probably a good idea to state more clearly in the docs what 'a jQuery object representing a set of form elements' means.

comment:4 Changed 8 years ago by ddewit

cool

Note: See TracTickets for help on using tickets.