Bug Tracker

Opened 5 years ago

Closed 5 years ago

Last modified 5 years ago

#15153 closed bug (duplicate)

KeyError: 'captcha_redirect'

Reported by: bsuagher Owned by:
Priority: undecided Milestone: None
Component: unfiled Version: 1.11.1
Keywords: Cc:
Blocked by: Blocking:

Description

How to Reproduce

While doing a POST operation on /, Trac issued an internal error.

(please provide additional details here)

Request parameters:

{'__FORM_TOKEN': u'53d64128e10fa4759619c2a0',
 'recaptcha_challenge_field': u'03AHJ_Vut4yx_ENOx0SfnkF7C9Isl3iMEup8ceMhOvM57oJeiL8Qp-7dk8D_hyb8glUz7FrAMmmEh2LtnOhu_XdJPC6mt0azXCzAgdCtqJg11ZjFiaDL8S3L3l5OA6vrUA64U8VDfVA20iboawxbHnfWi6koE35vhb2bKMkAsrRu73Gky1zBpmGunQnzvExclr7rbsgfRlkwQGLzvcv5SrzUN5aCnHh0QcGQ',
 'recaptcha_response_field': u'Thomas hatssee'}

User agent: Mozilla/5.0 (Windows NT 6.1) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/35.0.1916.153 Safari/537.36

System Information

System information not available

Enabled Plugins

Plugin information not available

Python Traceback

Traceback (most recent call last):
  File "/usr/local/lib/python2.6/dist-packages/Trac-0.12.1-py2.6.egg/trac/web/main.py", line 511, in _dispatch_request
    dispatcher.dispatch(req)
  File "/usr/local/lib/python2.6/dist-packages/Trac-0.12.1-py2.6.egg/trac/web/main.py", line 202, in dispatch
    chosen_handler)
  File "/usr/local/lib/python2.6/dist-packages/Trac-0.12.1-py2.6.egg/trac/web/main.py", line 344, in _pre_process_request
    chosen_handler = filter_.pre_process_request(req, chosen_handler)
  File "/usr/local/lib/python2.6/dist-packages/TracSpamFilter-0.4.1dev_r10170-py2.6.egg/tracspamfilter/captcha/api.py", line 119, in pre_process_request
    del req.session['captcha_redirect']
KeyError: 'captcha_redirect'

Change History (2)

comment:1 Changed 5 years ago by timmywil

Resolution: duplicate
Status: newclosed

Duplicate of #13676.

comment:2 Changed 5 years ago by timmywil

#15154 is a duplicate of this ticket.

Note: See TracTickets for help on using tickets.