Bug Tracker

Opened 9 years ago

Closed 8 years ago

#15078 closed bug (migrated)

Fix release script

Reported by: dmethvin Owned by:
Priority: low Milestone: 1.12/2.2
Component: build Version: 1.11.1
Keywords: Cc: scott_gonzalez
Blocked by: Blocking:

Description (last modified by dmethvin)

This is a meta-ticket for the problems I encountered during the 1.11.1/2.1.1 release, some of these will be jquery-release issues and others with core's release.js script.

  • The 1.x release tries to update jquery.js and jquery-latest.js on the CDN and fails, we if we're not going to update these anymore and freeze them at 1.11.1 we can just remove that from core's release.js.
  • I've now had npm publish --tag fail on me in two different releases. It worked for the 2.x but failed on 1.x. As a result I ended up doing the subsequent steps manually there. (Note that npm publish --tag 1.x worked fine manually both times!) Since npm is independent from the later steps there should be an idea of "error but you can continue" in jquery-release to simplify error recovery and minimize the mess.
  • The CDN zip files created by release.js were empty (0 bytes) for the 2.x release. I didn't get that far with 1.x because of the npm error.
  • The build script never came back to a shell prompt even after I got the "complete" message; perhaps related to why the zip files were empty.
  • The version wasn't updated in bower.json either, it was in the old non-semver format as well. Does this need to be in the repo full-time, or can it just exist in the tagged release?

Change History (2)

comment:1 Changed 9 years ago by dmethvin

Cc: scott_gonzalez added
Component: unfiledbuild
Description: modified (diff)
Milestone: None1.12/2.2
Priority: undecidedlow
Status: newopen

comment:2 Changed 8 years ago by m_gol

Resolution: migrated
Status: openclosed
Note: See TracTickets for help on using tickets.