Bug Tracker

Opened 6 years ago

Closed 6 years ago

#14874 closed bug (invalid)

FadeIn fail to draw an empty element over the entire page if a flash object is present in the page

Reported by: happypoulp@… Owned by: happypoulp@…
Priority: undecided Milestone: None
Component: unfiled Version: 1.11.0-rc1
Keywords: Cc:
Blocked by: Blocking:

Description

Hi,

Bug demo here: http://jsfiddle.net/L57pz/9/

When a flash is present and visible in the page, "fadeIn" method fails to show the #dimmer element (#dimmer is an empty element that is supposed to cover the entire page). It is correctly inserted but not drawn (it stays invisible). When the flash element is hidden, the bug does not occur.

Reproduced on Chrome Version 33.0.1750.146 on Mac Os X 10.8.5 and 10.9.1 with jQuery 1.9.0 and above. This issue is not present on Firefox (version 27.0.1).

I don't know if it may help but adding a content to the element #dimmer seems to fix the issue (see jsFiddle).

What's expected: the element should be visible after fadeIn has been called on it.

Thanks.

Change History (3)

comment:1 Changed 6 years ago by dmethvin

Owner: set to happypoulp@…
Status: newpending

I can reproduce the problem but don't have any idea on a solution. Also I'm not sure this is something we can fix inside jQuery. You mention that this is 1.9.0 and later but I don't see it working properly on older versions in your demo. Was there any version where jQuery worked? If not I suspect some browser-specific bug.

comment:2 Changed 6 years ago by anonymous

I mentionned jQuery 1.9.0 because it was the lowest version I tested with but you may be right, maybe this never worked in any version of jQuery. It seems indeed to be a browser specific issue but I thought that jQuery was supposed to address those kind of cross-browser subtilities. And since it just occurs with an animation function like fadeIn and not via a direct display it's more like a jQuery animate + Chrome specific issue.

However, I do understand to difficulty (impossibility?) to provide a generic fix for this bug.

Thanks.

comment:3 Changed 6 years ago by trac-o-bot

Resolution: invalid
Status: pendingclosed

Because we get so many tickets, we often need to return them to the initial reporter for more information. If that person does not reply within 14 days, the ticket will automatically be closed, and that has happened in this case. If you still are interested in pursuing this issue, feel free to add a comment with the requested information and we will be happy to reopen the ticket if it is still valid. Thanks!

Note: See TracTickets for help on using tickets.