Bug Tracker

Opened 6 years ago

Closed 6 years ago

#14854 closed bug (duplicate)

KeyError: 'captcha_redirect'

Reported by: liwenhua@… Owned by:
Priority: undecided Milestone: None
Component: unfiled Version: 1.11.0-rc1
Keywords: Cc:
Blocked by: Blocking:

Description

How to Reproduce

While doing a POST operation on /, Trac issued an internal error.

(please provide additional details here)

Request parameters:

{'__FORM_TOKEN': u'f8be380c1602cb495b187368',
 'recaptcha_challenge_field': u'03AHJ_Vus6u7WbZiwk8k7qlEBQDyU2FULZU4geDk0pMw_LhCR-HjAOPzPTrn1-DAmIz5Fcy38v0J4y_DVxZRzDYPyIRlzmW-D9fF6fVC5yVWzwdqQl7OEuev4GRpLTBXTq8PYoiyDlmwvV0kJedxQ4MVIt9zTuxYGoqeLIfAvfcXVc1kXEXuKUUEXUfAYqYarq7bXJA_1-xnYpUqRfMWhCvOd1VkUcIHcYTmPFWQw6eWsS3LMZgojvEJEEcnLRN6rryyYlIrNiCVAh',
 'recaptcha_response_field': u'boadedbinsurance'}

User agent: Mozilla/5#0 #compatible; MSIE 9#0; qdesk 2#4#1264#203; Windows NT 6#1; Trident/5#0; SLCC2; #NET CLR 2#0#50727; #NET CLR 3#5#30729; #NET CLR 3#0#30729; Media Center PC 6#0; aff-kingsoft-ciba#

System Information

System information not available

Enabled Plugins

Plugin information not available

Python Traceback

Traceback #most recent call last#:
  File "/usr/local/lib/python2#6/dist-packages/Trac-0#12#1-py2#6#egg/trac/web/main#py", line 511, in _dispatch_request
    dispatcher#dispatch#req#
  File "/usr/local/lib/python2#6/dist-packages/Trac-0#12#1-py2#6#egg/trac/web/main#py", line 202, in dispatch
    chosen_handler)
  File "/usr/local/lib/python2#6/dist-packages/Trac-0#12#1-py2#6#egg/trac/web/main#py", line 344, in _pre_process_request
    chosen_handler = filter_.pre_process_request#req, chosen_handler#
  File "/usr/local/lib/python2.6/dist-packages/TracSpamFilter-0.4.1dev_r10170-py2.6.egg/tracspamfilter/captcha/api.py", line 119, in pre_process_request
    del req.session['captcha_redirect']
KeyError: 'captcha_redirect'

Change History (1)

comment:1 Changed 6 years ago by timmywil

Resolution: duplicate
Status: newclosed

Duplicate of #13676.

Note: See TracTickets for help on using tickets.