Bug Tracker

Opened 6 years ago

Closed 6 years ago

#14821 closed bug (duplicate)

$.extend - circular references - error: "Maximum call stack size exceeded"

Reported by: vic Owned by:
Priority: undecided Milestone: None
Component: unfiled Version: 2.1.0
Keywords: Cc:
Blocked by: Blocking:

Description

Circular references causes error: "Maximum call stack size exceeded"

var b = {

prop_b: "bbbb"

};

var a = {

prop_a: "aaaa", b: b

};

b.ba = {

a: a

};

$.extend(true, a, b);ERROR "Maximum call stack size exceeded"

http://jsfiddle.net/DWbqP/

Change History (1)

comment:1 Changed 6 years ago by dmethvin

Resolution: duplicate
Status: newclosed

Duplicate of #12227.

Note: See TracTickets for help on using tickets.