Bug Tracker

Opened 13 years ago

Closed 13 years ago

#1475 closed bug (fixed)

clone() stop event propagation

Reported by: gregoire.cachet Owned by:
Priority: minor Milestone: 1.2.2
Component: event Version: 1.1.3
Keywords: Cc:
Blocked by: Blocking:

Description

I'm trying to clone() a DOM node during a change event on this node.

It appears that it stop the propagation of my change event (actually it should call another callback function after the callback who clones the node, that's how I noticed because it wasn't called).

It works fine with the DOM cloneNode() method.

I'm running Firefox 2.0.0.6.

Attachments (1)

jquery_test.html (1.1 KB) - added by davidserduke 13 years ago.
test case (built based on description)

Download all attachments as: .zip

Change History (4)

comment:1 Changed 13 years ago by john

Component: coreevent
Milestone: 1.1.4

comment:2 Changed 13 years ago by brandon

need: ReviewTest Case

Changed 13 years ago by davidserduke

Attachment: jquery_test.html added

test case (built based on description)

comment:3 Changed 13 years ago by davidserduke

Milestone: 1.1.41.2.2
Resolution: fixed
Status: newclosed

I was unable to reproduce this in the current SVN. Clone has changed quite a bit since 1.1.3 so I'm going to mark this as fixed. If the test case isn't what you had in mind feel free to reopen the bug and attach one that shows the problem.

Note: See TracTickets for help on using tickets.