Bug Tracker

Opened 6 years ago

Closed 6 years ago

Last modified 6 years ago

#14727 closed bug (invalid)

after select options

Reported by: Alidad@… Owned by: Alidad@…
Priority: undecided Milestone: None
Component: unfiled Version: 1.10.2
Keywords: Cc:
Blocked by: Blocking:

Description

Hi, there might be a bugs relate to select options using <options> or <ul li>.

For sample that there is blue box with rounded corner is 1px which stright, and when click the button it will change blue box rounded corner to 5px, however i want to change rounded corner again AFTER SELECTED FROM DROP MENU, but is not working, i even try with ui or li is not working. Even if i want to change text color to different color after selected from drop menu is not working. So basically i'm trying to say that there might be bug that jquery is not doing any action after selected from options.. here is my sample of code.

$(document).ready(function(){
		$(".customSelect").click(function() {
  $("#search-background").css("border-bottom-left-radius","5px");
  
   });
				
		});
		$(document).ready(function(){
$(".select.custom").click(function(){
  $("#search-background").css("border-bottom-left-radius","25px");
   });   });

Change History (5)

comment:1 Changed 6 years ago by m_gol

Owner: set to Alidad@…
Status: newpending

Thanks for taking the time to contribute to the jQuery project! Please provide a complete reduced test case on jsFiddle to help us assess your ticket!

Additionally, be sure to test against the "jQuery 1.x (edge)" or "jQuery 2.x (edge)" version to ensure the issue still exists—you may need to change this to a specific version depending on the test case.

For the AJAX-related tests you can create a few fiddles and submit requests to addresses with "/show/light" added to the end of the URL; example: http://jsfiddle.net/m_gol/3hwjC/17/show/light/

To get you started, use the appropriate boilerplate:

Open the link and click to "Fork" (in the top menu) to begin.

Also, please read:

Additional resources:

comment:2 Changed 6 years ago by anonymous

Hi thank yous so much for your response, I recently update in jsfiddle.net here is the link...

http://jsfiddle.net/alijan20/SFUj3/3

As you can see when loaded is show (search-background) rounded-border to 5px,

And what i'm trying to do is that when pressing menu button is change search background left bottom border radius to 1px.

And than when selected any options from menu than change search background left bottom border radius back to 5px.

I have tried that is not working is this works in jquery!

please let me know thanks.

AM

comment:3 Changed 6 years ago by trac-o-bot

Resolution: invalid
Status: pendingclosed

Because we get so many tickets, we often need to return them to the initial reporter for more information. If that person does not reply within 14 days, the ticket will automatically be closed, and that has happened in this case. If you still are interested in pursuing this issue, feel free to add a comment with the requested information and we will be happy to reopen the ticket if it is still valid. Thanks!

comment:4 Changed 6 years ago by anonymous

I have response that please see second comment, with sample of link from jsfiddle.com, i guess no one have read my response and did not reply me that why they close my case, I like to reopen that case and have someone reply me how to solve that please.

please let me know asap thanks.

Alidad

comment:5 Changed 6 years ago by rvidal

Not a bug. In your code, $('.customSelect') and $('.select.custom') are empty. You can find further help about using jQuery in the Using jQuery forum.

Note: See TracTickets for help on using tickets.