Bug Tracker

Opened 6 years ago

Closed 6 years ago

#14671 closed bug (worksforme)

AJAX not working in Firefox 26.0 on Windows

Reported by: mortenm Owned by: mortenm
Priority: undecided Milestone: None
Component: unfiled Version: 1.10.2
Keywords: Cc:
Blocked by: Blocking:

Description

AJAX works perfect for most platforms and browsers. However, for Firefox 26.0 running on Windows there is a problem. Firebug reports that the AJAX response is arrived OK without problems, but jQuery stalls and after some timeout period it chooses to do an error callback. It does not matter if dataType is JSON or JSONP.

The error can be re-tested on https://workrecording-workrecording.rhcloud.com/dagsseddel/Frontend/WebApp/index.html#SettingsPage by using credentials demo/demo/demo

Is there a fix to this problem?

Change History (6)

comment:1 Changed 6 years ago by m_gol

Owner: set to mortenm
Status: newpending

I can't reproduce it on your test case. Please, try with a fresh Firefox profile, maybe some extension is causing that (which would make it outside of the scope of jQuery).

comment:2 Changed 6 years ago by anonymous

We are also seeing this issue on a new site, worked fine on 25, intermittent on 26

comment:3 Changed 6 years ago by anonymous

Same here - FF26 fails intermittently, FF25 was ok

comment:4 Changed 6 years ago by mortenm

Status: pendingnew

It seems that the combination of Firebug and jQuery AJAX is the problem. When Firebug is deactivated then there is no problem - every AJAX response is retrieved correctly. But I cannot figure out if Firebug, jQuery or the combination is to blame the problem?

Last edited 6 years ago by mortenm (previous) (diff)

comment:5 Changed 6 years ago by dmethvin

Since jQuery works fine with Firefox, someone should triage the Firebug issue with the Firebug team.

comment:6 Changed 6 years ago by jaubourg

Resolution: worksforme
Status: newclosed

I agree with dmethvin. Seems like something which firebug relied on changed in FF 26.

I'll close this as worksforme.

Note: See TracTickets for help on using tickets.