Bug Tracker

Opened 6 years ago

Closed 6 years ago

Last modified 6 years ago

#14604 closed bug (duplicate)

KeyError: 'captcha_redirect' bug while trying to submit a bug

Reported by: rainabba@… Owned by:
Priority: undecided Milestone: None
Component: unfiled Version: 1.10.2
Keywords: Cc:
Blocked by: Blocking:

Description

How to Reproduce

While doing a POST operation on /, Trac issued an internal error.

(please provide additional details here)

Request parameters:

{'__FORM_TOKEN': u'462335454b3835b35f45afeb',
 'recaptcha_challenge_field': u'03AHJ_VuuRRNHtZe1wNqd3XsSke-mwDC95CO0K7fEK3ufy-jKwz0_xwL_slyJr6iP9_N8Lh36FkROmDDgFfsyMRh_ZZuKv8-wVBd1WPFVxKbY-dgD5nbK63GApqkxUzMt-GVUwkQ2DHT8g08GVysYBt95ykIP0chUlIMh_qed46Ja7PcOuOnf-ZtI',
 'recaptcha_response_field': u'22 65999549'}

User agent: Mozilla/5.0 (Windows NT 6.3; WOW64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/33.0.1726.0 Safari/537.36

System Information

System information not available

Enabled Plugins

Plugin information not available

Python Traceback

Traceback (most recent call last):
  File "/usr/local/lib/python2.6/dist-packages/Trac-0.12.1-py2.6.egg/trac/web/main.py", line 511, in _dispatch_request
    dispatcher.dispatch(req)
  File "/usr/local/lib/python2.6/dist-packages/Trac-0.12.1-py2.6.egg/trac/web/main.py", line 202, in dispatch
    chosen_handler)
  File "/usr/local/lib/python2.6/dist-packages/Trac-0.12.1-py2.6.egg/trac/web/main.py", line 344, in _pre_process_request
    chosen_handler = filter_.pre_process_request(req, chosen_handler)
  File "/usr/local/lib/python2.6/dist-packages/TracSpamFilter-0.4.1dev_r10170-py2.6.egg/tracspamfilter/captcha/api.py", line 119, in pre_process_request
    del req.session['captcha_redirect']
KeyError: 'captcha_redirect'

Change History (2)

comment:1 Changed 6 years ago by timmywil

Resolution: duplicate
Status: newclosed

Duplicate of #13676.

comment:2 Changed 6 years ago by timmywil

#14603 is a duplicate of this ticket.

Note: See TracTickets for help on using tickets.