Bug Tracker

Opened 13 years ago

Closed 12 years ago

#1460 closed enhancement (duplicate)

Allow basic markup syntax in tooltips

Reported by: lrbabe Owned by: stefan
Priority: minor Milestone: 1.1.4
Component: interface Version: 1.1.3
Keywords: tooltip Cc:
Blocked by: Blocking:

Description

We should allow a few markup conversion for titles used in tooltips. for exemple, this title :

title="heading :: some info | another info"

(note that the title remains understandable and valid without conversion), could be rendered as :

<div id="tooltipHelper">

<div id="tooltipTitle">

<hX>heading</hX> some info<br /> another info

</div> <div id="tooltipURL"> </div>

</div>

the only thing to do actually is to replace line 65 of iTooltip by : jQuery('#tooltipTitle').html(title.replace(/(.*?)::/, "<h4>$1</h4>").replace(/ \| /g, "<br />"));

An option could be added to ignore conversion...

PS : Excuse my poor english, I'm just a young french.

Change History (1)

comment:1 Changed 12 years ago by scott.gonzal

Resolution: duplicate
Status: newclosed

duplicate of #1459

Note: See TracTickets for help on using tickets.