Bug Tracker

Opened 6 years ago

Closed 6 years ago

#14597 closed bug (duplicate)

$.serialize, $.serializeArray and input with name "elements"

Reported by: bodyaga Owned by:
Priority: undecided Milestone: None
Component: unfiled Version: 1.10.2
Keywords: Cc:
Blocked by: Blocking:

Description

http://jsfiddle.net/bodyaga/KJLxA/1/

in this example output data from $.serialize() must be

foo=foo&boo=boo&elements=bug

but, it's only

elements=bug

$.serialize() and $form.serializeArray() return incorrect data if at form present input's named "elements"

duplicate for closed ticket @14594

Change History (2)

comment:1 Changed 6 years ago by bodyaga

bug can be represent at any version of jQuery and any browser

comment:2 Changed 6 years ago by timmywil

Resolution: duplicate
Status: newclosed

Duplicate of #14594.

Note: See TracTickets for help on using tickets.