Bug Tracker

Opened 6 years ago

Closed 6 years ago

#14591 closed bug (duplicate)

Issue in .html()

Reported by: ravindra.alld@… Owned by:
Priority: undecided Milestone: None
Component: unfiled Version: 1.10.2
Keywords: Cc:
Blocked by: Blocking:

Description

Hi,

When I use .html (String) method where string has some java script. After apply .html its fails and give error as

Uncaught SyntaxError: Unexpected token < jquery-1.10.2.js:612 <https://localhost:7004/XYZ/JS/jquery-1.10.2.js>(anonymous function)jquery-1.10.2.js:612

The same piece of code is working fine in jQuery 1.9.1. I debug the issue and got a point that the text which is appended by the .html method has some java script inside it and also has the < sign in a for loop.

Please suggest the appropriate way of solving this issue.

Change History (1)

comment:1 Changed 6 years ago by timmywil

Resolution: duplicate
Status: newclosed

Duplicate of #14590.

Note: See TracTickets for help on using tickets.