Bug Tracker

Opened 6 years ago

Closed 6 years ago

#14580 closed bug (invalid)

Nested $(doc).ready calls don't work in IE9 or lower

Reported by: jaquers@… Owned by: jaquers@…
Priority: undecided Milestone: None
Component: unfiled Version: 1.10.2
Keywords: Cc:
Blocked by: Blocking:

Description

I'm not necessarily advocating this as good practice, just reporting the behavior.

Might duplicate #10010.

http://jsfiddle.net/ysd6U/1/

Expected behavior: Separate alert for each element that matches #things li

Browsers

Chrome: PASS

Firefox: PASS

IE10: PASS

IE9: FAIL

IE8: FAIL

function Thing(el) {
    $(document).ready(function() {
        alert($(el).attr('class'));
    });
}

$(document).ready(function() {
    $('#things li').each(function() {
        var thing = new Thing(this);
    });
});

Change History (2)

comment:1 Changed 6 years ago by dmethvin

Owner: set to jaquers@…
Status: newpending

This seems to work fine in edge, can you confirm?

http://jsfiddle.net/ysd6U/2/

comment:2 Changed 6 years ago by trac-o-bot

Resolution: invalid
Status: pendingclosed

Because we get so many tickets, we often need to return them to the initial reporter for more information. If that person does not reply within 14 days, the ticket will automatically be closed, and that has happened in this case. If you still are interested in pursuing this issue, feel free to add a comment with the requested information and we will be happy to reopen the ticket if it is still valid. Thanks!

Note: See TracTickets for help on using tickets.