Bug Tracker

Opened 5 years ago

Closed 5 years ago

#14565 closed bug (wontfix)

slideToggle callback error causes infinite loop

Reported by: anonymous Owned by:
Priority: undecided Milestone: None
Component: unfiled Version: 1.10.2
Keywords: Cc:
Blocked by: Blocking:

Description (last modified by timmywil)

I have a case where I am calling .each from within the callback of slideToggle. If an error happens inside that .each, an infinite loop is created and the error repeats forever.

I have an example showing how the problem is isolated to the slideToggle callback. This seems to happen in all versions.

http://jsfiddle.net/wvyNz/15/

Change History (4)

comment:1 Changed 5 years ago by timmywil

Description: modified (diff)

comment:2 Changed 5 years ago by timmywil

This seems like another case where we would have to catch the exception, which jQuery avoids for debugging purposes. What are the team's thoughts on the desired behavior here?

comment:3 Changed 5 years ago by dmethvin

It's not a "loop", the animation just fails to progress because of the error. If you open the console and look at the trace, the error message makes it pretty clear where the problem is happening. Swallowing the error would obfuscate things and make it difficult to debug. I'd vote for leaving it as is.

comment:4 Changed 5 years ago by timmywil

Resolution: wontfix
Status: newclosed

Agreed.

Note: See TracTickets for help on using tickets.