Bug Tracker

Opened 6 years ago

Closed 6 years ago

#14556 closed bug (duplicate)

outerWidth(true) off by one pixel in IE 11 and FF 25 but not Chrome 31

Reported by: me@… Owned by:
Priority: undecided Milestone: None
Component: unfiled Version: 2.0.3
Keywords: Cc:
Blocked by: Blocking:

Description

http://jsfiddle.net/aC5M6/

In the above Fiddle, the existence of font-family: sans-serif in the * selector causes IE 11 and FF 25 to calculate an outerWidth(true) that is one pixel too small, causing some li elements to wrap. Chrome 31 renders the li elements just fine in either case. Rem

I first encountered this bug while using SimpleModal 1.4.4, which uses jQuery's outerWidth(true) method to calculated a modal dialog's width.

Change History (4)

comment:1 Changed 6 years ago by me@…

Note that I am testing this on Windows 8.1 Pro with ClearType turned on.

comment:3 Changed 6 years ago by me@…

One additional note: this bug occurs in IE 9+ (tested by using IE 11's document modes).

comment:4 Changed 6 years ago by dmethvin

Resolution: duplicate
Status: newclosed

Duplicate of #9628.
The SO thread referenced in comment 2 explains the problem, we already have an open ticket #9628 for it so I will close this as a dup.

The solution is complicated because a lot of code will break if we just start returning non-integer values. Also, .width() and .height() will attempt to determine the actual dimensions of elements currently set to display: none which requires temporary swapping of display properties.

Note: See TracTickets for help on using tickets.