Bug Tracker

Opened 6 years ago

Closed 6 years ago

#14457 closed bug (duplicate)

.text() problem with IE 11 Release Preview

Reported by: warlock Owned by:
Priority: undecided Milestone: None
Component: unfiled Version: 1.10.2
Keywords: Cc:
Blocked by: Blocking:

Description

I've been working on my site and encountered an error when using the .text() function. An example of the problem can be seen here:

http://jsfiddle.net/VBQx4/

In Chrome 30 and Firefox 24, the .text() function when called against an <li> node, returns the expected output "car" or "truck" respectively. However, in IE 11 Release Preview, .text() is returning the bullet from the <li> node in the list in front of the text like so "*car" "*truck" (the asterisk represents the bullet). That's as close as I could come to demonstrating the error that occurs. The alert box in the example above, when run in IE 11 Release Preview, clearly shows the bullet returned in the .text() function. I noticed this error because the text is used as a property of an object (or key in an associative array, whichever you prefer). With the "*" (bullet), the key is not found and an error is throw in my code.

I'm not sure the desired output of the .text(). Maybe the bullet should be returned, maybe it shouldn't. However, I figure the output of the function should be consistent.

I went back and tested in IE 9 and IE 10 and the function works as desired, returning only "car" or "truck" respectively without the bullet.

Change History (1)

comment:1 Changed 6 years ago by timmywil

Resolution: duplicate
Status: newclosed

Duplicate of #14456.

Note: See TracTickets for help on using tickets.