Skip to main content

Bug Tracker

Side navigation

#14428 closed feature (plugin)

Opened October 08, 2013 01:46AM UTC

Closed October 13, 2013 12:18PM UTC

Last modified October 14, 2013 05:28AM UTC

Change .add() to .and()

Reported by: Owned by:
Priority: undecided Milestone: None
Component: unfiled Version: 1.10.2
Keywords: Cc:
Blocked by: Blocking:

The "add" name is confusing. Does it add to the original element list? Does it add it as a children?

$(this).and(that).doSomething(); would be more readable.

Attachments (0)
Change History (2)

Changed October 13, 2013 12:18PM UTC by dmethvin comment:1

resolution: → plugin
status: newclosed

The API has been there for years and nobody has been confused about it. We couldn't *rename* it without breaking code so the only thing we could do is add an alias. If that's the case, it can be done in your code.

Changed October 14, 2013 05:28AM UTC by comment:2

Ugh. What about .andSelf()? Wasn't that deprecated and aliased to .addBack() for clarity?

I'm not asking this for myself, but for the community. I already know how .add() works