#14428 closed feature (plugin)
Change .add() to .and()
Reported by: | Owned by: | ||
---|---|---|---|
Priority: | undecided | Milestone: | None |
Component: | unfiled | Version: | 1.10.2 |
Keywords: | Cc: | ||
Blocked by: | Blocking: |
Description
The "add" name is confusing. Does it add to the original element list? Does it add it as a children?
$(this).and(that).doSomething(); would be more readable.
Change History (2)
comment:1 Changed 10 years ago by
Resolution: | → plugin |
---|---|
Status: | new → closed |
comment:2 Changed 10 years ago by
Ugh. What about .andSelf()? Wasn't that deprecated and aliased to .addBack() for clarity?
I'm not asking this for myself, but for the community. I already know how .add() works
Note: See
TracTickets for help on using
tickets.
The API has been there for years and nobody has been confused about it. We couldn't *rename* it without breaking code so the only thing we could do is add an alias. If that's the case, it can be done in your code.