Bug Tracker

Opened 6 years ago

Closed 6 years ago

#14360 closed bug (duplicate)

parseJSON gives error with unobstusive validation

Reported by: hindn@… Owned by:
Priority: undecided Milestone: None
Component: unfiled Version: 1.9rc1
Keywords: Cc:
Blocked by: Blocking:

Description

Line 540 : if ( window.JSON && window.JSON.parse ) { return window.JSON.parse( data ); }

Problem : because data is undefined it gives us an error. solution : check if data is undefined if yes return null before the native json parse check

Change History (1)

comment:1 Changed 6 years ago by dmethvin

Resolution: duplicate
Status: newclosed

Duplicate of #13430.

Note: See TracTickets for help on using tickets.