Bug Tracker

Opened 13 years ago

Closed 12 years ago

#1431 closed bug (worksforme)

Bug in Animations

Reported by: tmferreira Owned by:
Priority: major Milestone: 1.2.2
Component: effects Version: 1.1.3
Keywords: animate function Cc:
Blocked by: Blocking:

Description

Hi! I detect a bug using the animate function.

See the difference between firefox and internet explorer: http://www.tmferreira.com.br/blog/wp-content/animacoes-em-javascript-com-jquery/index_lateral.html

I am using FireFox 2.0 e Internet Explorer 6.0. Using FF, there are an interpolation, but using IE, the box moves hides and shows on the right.

Sorry my poor English. I am Brazilian.

Bye.

Change History (3)

comment:1 Changed 13 years ago by john

Component: corefx
Priority: criticalmajor

comment:2 Changed 12 years ago by davidserduke

I can't reproduce this bug so it might be fixed.

Based on the description this might have been caused by a pause in the browser. The way the animation system works is by use setInterval. And when the "step" function is called it calculates where the animated object is supposed to be based on the start time of the animation and the current time. The result is if the browser is busy and doesn't get to call the setInterval function quickly enough it will look like it is jumping as it tries to keep up with the animation speed. Under an extreme case (in this test case it would mean the function wasn't called for 600ms) the animated object would seem to disappear and just show up at its end point.

That may or may not have been what the bug reporter saw, but I can't reproduce his problem in IE6 at the moment.

comment:3 Changed 12 years ago by davidserduke

Milestone: 1.1.41.2.2
Resolution: worksforme
Status: newclosed

I'm afraid it still works for me. I don't see the problem in my IE6.

Note: See TracTickets for help on using tickets.